ROS反向代理实现同外网80端口多Web服务

利用ROS如何做到一公网同时提供多WEB服务……

直接进入主题:

roswebproxy

下面是操作步骤,文笔不好,请大家见谅……

环境如下:

sxt1.ros.tw 192.168.99.2

sxt2.ros.tw 192.168.99.3

两IP为不同版本ROS以示区分

一、启用ROS的Web Proxy功能

/ip web-proxy 
set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \ 
transparent-proxy=yes parent-proxy=0.0.0.0:0 \ 
cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \ 
max-cache-size=unlimited max-ram-cache-size=unlimited 
/ip web-proxy access 
add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \ 
disabled=no 
add dst-port=80 action=allow comment="Enable Http Connection" disabled=no 

提示:web-proxy端口默认为8080,可根据情况自行修改。

二、设置静态DNS

/ip dns static add name=sxt1.ros.tw address=192.168.99.2
/ip dns static add name=sxt2.ros.tw address=192.168.99.3

三、设置重定向

1、80端口重定向

/ip firewall nat 
add chain=dstnat in-interface=出口网卡 dst-address=xxx.xxx.xxx.xxx protocol=tcp \ 
dst-port=80 action=redirect to-ports=8080 comment="" disabled=no 

提示:此处to-ports端口必须和上面web-proxy所设端口一致。

2、设置代理数据

/ip proxy access 
add dst-port=80 dst-host="sxt1.ros.tw" action=allow disabled=no
add dst-port=80 dst-host="sxt2.ros.tw" action=allow disabled=no
add action=deny disabled=no

做完后找外网朋友测试了下,sxt1.ros.tw域名打开页面为192.168.99.2的ROS管理页面、sxt2.ros.tw打开为192.168.99.3 ROS管理页面

总结:此方法用于企业多WEB服务器非常实用,不用为同为端口而发愁了,也免去改端口访问不方便;另外发现还省去了端口映射的操作,太省心了……

附官方截图:

20141128132347

标签

发表评论

CAPTCHAis initialing...

评论列表(15)

  • 137博客

    2019.8.20 16:08

    好文章,谢谢分享,我的博客,欢迎回访

    回复
  • 阿亮

    2018.7.5 19:07

    安装这个是实现了,流量一大ros就死机,不知道怎么优化

    回复
    • 草哥

      2018.7.6 08:07

      应该是你的设备性能不足的原因吧。有条件更换官方高配置的设备试试看。

  • 相公

    2017.3.8 10:03

    能不能实现外网80端口内网8000端口

    回复
    • 草哥

      2017.3.8 20:03

      那是可以的,很明显……

    • 相公

      2017.3.8 20:03

      求指教一二

    • 草哥

      2017.3.9 08:03

      就这么简单的问题,示例都有了还不会,那真没办法了……

    • 相公

      2017.3.9 18:03

      aaa.com访问到192.168.1.2的80端口
      bbb.com访问到192.168.1.2的8000端口
      和示例上的使用方法不一样

    • 草哥

      2017.3.9 19:03

      就改个端口号的问题……你纠结个什么呢??要会举一反三……

  • 华仔

    2017.3.7 20:03

    非80是不是只需要在设置代理数据那里端口设置为对应号?

    回复
    • 草哥

      2017.3.7 23:03

      端口对应着就可以了

  • 华仔

    2017.3.7 18:03

    内网可以用非80端口么?

    回复
    • 草哥

      2017.3.7 20:03

      端口不限的,80端口只是做测试。
      你知道文章主要讲的是什么吗??

  • 香港虚拟主机

    2015.1.26 10:01

    东西挺不错的,赞一个,支持支持!

    回复